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Banner Maker 1.2.5

Quick, How do I Make a Banner?

1) Double clicking on the Banner Maker icon, you will be presented with a dialog containg the
default banner text.

Top Line:

Middle Line: (Maker

Bottom Line: (Uersion 1.2.5

2) Enter the text you want on your banner and click OK.

Top Line: Good Luck

Middle Line: (Mr. & Mr.

Cancel

Bottom Line: |Jackson

3) A window containg your banner will appear
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4) Change the font and style if you wish using the pull down menus.
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" & rite coit Tl size style

1-800-Monotype
AGaramond
AGaramond Italic
AGaramond Semibold

AGaramond Semibolditalic =i

Auant Garde S[I=———— Untitlled

Biffo MT
Bookman
Brush Script
Charter BT
Chicago
Concertivare
Courier
Cmbassy DT
Geneva
Handwriting
Helvetica
Kells
Linoscript
Linotent
.| Monaco
N Heluetica Narrow
New Century Schibk
New York
' 01d styic MT Bold outiine
Palatino

Park Avenue
sansserif
stencil B

Zapf Chancery
2apf Dingbats
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5) Choose Save from the File menu and save your banner. It is always a good idea to save your

work before you print.

E:mé%m Edit Font Size Style
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1 Open 0
Close L

Page Setup...
Print... *®P
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6) Choose Page Setup from the File menu and insure that Landscape (sideways) printing and no
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Save Banner As:

| Wedding Banner|

— Development
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Hasking

gaps between pages are selected as shown below.

) Computer Paper
Orientation Special Effects:

Imagelriter
Paper: @ US Letter A4 Letter
{3 US Legal

¥ International Fanfold

[ ¥ait B gustad
050 % Reduction
[]No Gaps Between Pages

7) Choose Print from the File menu and click Print.

Imagellriter

Page Range: @ All
Copies:

Ouality: 1 Best ) Faster O Brafi

) From: I:I To: I:I

Paper Feed: (@® Automatic ) Hand Feed

8) Go get a pizza, banners take lots of time to print.

4 0f 13

1.2.5



Banner Maker

Banner Maker: Printing software for the Apple Macintosh

What is Banner Maker?

Banner Makers is a full featured banner printing application for the Apple Macintosh.
Features:

1) Prints very large banners using both ATM™ and TrueType™ outline fonts.

2) Floating text allows for great text effects

3) Supports inport of graphics via the clipboard.

4) Alignment of graphic objects.

5) Save banners for reuse at a later date.

The Banner Maker Window.

Below is a picture a Banner Maker window. Please note the landscape/protrait indicator. This
indicator is designed to show you the orientation you have selected in the Page Setup dialog.
Normaly you will want to print in landscape mode (shown) if a question mark appears in this area,
your printer driver can not tell Banner Maker which mode you have selected in the Page Setup
Dialog.

r

% File Edit Font Size Style
EC] Untitled

Current Page Protrait/Landscape
& Printing

Total Pages

Within the window you should also notice the light gray lines, these lines show you where the
pages break on the banner. As you move items in the banner, you may notice that the number of
pages the banner contains is automaticly updated for you.
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Banner Maker 1.2.5

Text

Entering Text onto the banner:
There are two kinds of text allowed on a banner, fixed text and floating text.

Fixed text is thought of as the background text. Normaly fixed text is the very large part of the
banner. When you select New from the File menu, you are prompted for the fixed text.

The number of lines of fixed text is limited by the font size currently selected. With 120 point text,
three lines of text will fit nicely on a horizontal ImageWriter page. 240 point allows for two lines
of text, and 480 for only one line of fixed text. (The appendix has some interesting information
about changing these values)

The term Fixed Text must be used loosely however. The text is fixed in that you canNOT make
any adjustments to its size or placement that are not found in the pulldown menus.

Floating text, on the other hand, moves around on the screen just like any picture in MacDraw™.
To enter new floating text choose New Floating Text from the Edit menu. This text may be moved
and resized just like a picture in most drawing programs. Using this feature you can get some very
interesting effects.

Floating text is placed onto the banner using the current Size, Font and Style selection in the
MenuBar. Once a piece of floating text is created, its font and style can be changed by selecting
the text item and choosing the appropreate menus. The size can be changed by dragging the
handles of selected floating text.
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Graphics

Pasting Graphics onto the Banner

After copying a picture onto the clipboard from another application or desk accessory, you can
choose Paste from the Edit menu Each pasted graphic will appear either at the last “mouse click”
location or in the upper left hand corner of the banner window.

Changing Picture Sizes

Notice the eight handles (blocks) surrounding the picture below. You can change the size of any
picture or floating text you have pasted onto the banner by dragging any one of these handles.

If after resizeing an object if you want to return it to its original size, hold down the command key
( 3) while clicking once on any handle.

Using both command key and option and command keys, click on any handle and you can resize
pictures by percentage. The percentage choosen must be an integer in the range of 10% to 1000%.

Resize Graphic:
Reduce or % of
Cnlarge: original size

Enter Only Integer “alues
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Reference:

Save 3
Save As...
J Page Setup ln n
Print...
Quil 30
R F a2 R
File Menu:

New Clears old banner from the screen and starts a new banner.

Open Open a previously saved banner.

Save Saves the banner you are currently working on to disk

Save As Save the banner you are currently working on to disk using a user supplied name.

Page Setup Tells banner maker how you would like the banner to appear on paper. The best setting
for the ImageWriter is Sideways, no gaps between pages.

Print Sends the banner to the printer. To cancel printing, click the cancel button. Printing will
occur in the background if you are running Multi-finder.

Quit Leave Banner Maker.
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[LiTIW Font  Size Style

#nin vy %
HEH H

fapy X

Paste #U

fipayr

HupHsate wi

select HIl #H

ffign Piotures..

Edit Banner Text #E
New Floating Text 3F

Edit Menu:

Undo Here only for DA's, I don't have undo working yet.

Cut Copies the currently selected picture to the clipboard and deletes it from the
banner.

Copy Copies the currently selected picture to the clipboard.

Paste Places the contents of the clipboard onto the banner. Text is converted to a
picture. (You're going to LOVE this)

Clear Delete pictures from the banner (same as backspace key)

Duplicate Makes a copy of the selected picture(s) onto the banner. This is a quick copy
and paste.

Select All This is a quick way of selecting every picture on the banner.

Align Pictures Align the selected pictures in relation to each other.

Edit Banner Text Edit the master banner text.

New Floating Text  Enters new text onto the banner in a MacDraw like picture. The current font
and style are used.
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LI Size Style

Athens =

Bar Code 39 rem—

Bookman

Cairo
Chicago -
Courier

‘ FranklinGothic ‘
Geneva

H Franklin Gothic Heavy
Helvetica

L Helvetica Light
London

Los Angeles
Muobile
Monaco
Mew York

Park Arenue
San Francisco
Symbol

+Times
‘ / Uenice n

Font Menu:

Use this menu to select the current banner font. This effects the font for all of the lines of fixed
text in the banner. Existing floating text is not effected by a font change. New floating text will be
created with whatever font is currently selected.
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w120
240
480

Banne

m & R |

Size Menu:

The Size menu is used to change the size of fixed banner text. Use this menu to select the current
banner font size. If you would like to create text in a size other than those in the menu, you’ll need

to use floating text.

The number of banner lines is automaticaly adjusted by the size you pick.

120 - Three lines of text

240 - Two lines of text

480 - One line of text

Ton Line:
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" & File Edit Font size NN
= Flam

Bold #B
v FrEHE

Underline

0lujtllinte}

Shadaom

Condensed

Exdtended

wLeft Justify %[
Right Justify %1
Center Justify

Style Menu:

Plain Removes all styles

Bold Toggles the bold style

Italic Toggles the italic style

Underline Toggles the underline style

Outline Toggles the outline style

Shadow Toggles the shadow style

Condensed Toggles the condensed sytle (tighten up the characters)
Extended Toggles the extended sytle (allow extra space between characters)
Left Justify All lines of the banner will be flush left

Right Justify All lines of the banner will be right flush

Center Justify All lines of the banner will be centered on the banner pages
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Appendix A

Tricks of the Trade

Fonts

This software is designed to work only with outline fonts. If the screen display looks nasty, you
probably shouldn't expect “good things” to happen! Both ATM and True Type fonts work great!

Changing the defaults. (requires ResEdit knowledge!!!)

The default font, size and style of the banner maker is stored as a resource in the program itself.
With a copy of resedit you can copy the FINT (font information) resource from any of your saved
banners and paste it directly inside the Banner program.

The default strings are stored as resources STR 1024, 1025 and 1026 and may be changed as well.
By editing the MENU resources in the size menu, you can make “neat things” happen.

Changing the size menu

If you want to print banners with different sizes of fixed text, you can edit the size menu using
ResEdit from Apple Computer. The first three items in the menu control the number of fixed text
lines allowed on the banner.

Printing BIG banners.

If you used ATM:

The more RAM you have for ATM, the better this sofware will work! On a One Meg MacPlus,
you can play a nice game of RISK™ by the time a three page banner prints. But if you have Four
Meg of RAM in the same machine, and dedicate 1 meg to ATM, the same banner will print in 1/10
the time. In short, give ATM as much RAM as you can spare!

If you use TrueType (System 6.0.x requires an INIT, System 7.x has TrueType built in):

TrueType shares memory with the rest of the system. The more free memory available, the faster
banners will print.

Credits

Programming:

This program was written in Symantec’s Think Pascal
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Version Information!

1.2.5
1)
2)
3)

124
1)

123
1)
2)
3)
4)
5)
6)

1.2.2
1)
2)
3)

4)
5)

1.2.1
1)

11/13/92

Program used to crash if now window was open and the user switched apps.
Program is now 32 bit clean

Program tested to work with truetype.

1/1/92
Changed address in about boxes

12-13-89

Fixed drag selection rectangle problem when not at the beginning of the banner.
Fixed address error problem on non 32bit machines.

Added grabber hand scrolling. Press the option key and drag scrolls the window.
Added auto scroll when dragging pictures around the banner.

Floating text is now entered at 1/5 size of current banner size.

Added support for multiple windows.

12-4-89

Fixed page rectangle problems, should now print on all printers.

When a graphic causes the banner size to grow the extra pages are now printed.

When a graphic causes the banner size to changes and right or center alignment is selected, the entire screen is
redrawn.

Added portrait/landscape small icons in the page number area.

You can now change the text attributes in floating text.

11-30-89
Fixed problem with about box. replaced disposHandle with release resource.

14 of 13



Banner Maker 1.2.5

1.2.0
1)
2)
3)
4)
5)

1.1.2
1)
2)
3)
4)

1.1.1

1)
2)

1.0.1
1)
2)
3)
4)
5)
6)
7)

1.0.0
1)

11-30-89

Removed nVIR!!! Afar as I can tell, no infected copies where publicly posted!
Added Save before quitting.

Changed New in the File menu to mean totaly new clean banner

Added Edit banner text to the edit menu.

In general, this version is much more “Mac Like”

11-29-89

Fixed Zoom bug during alignment.

Fixed Zoom bug during resize object.

Graphics are now pasted in view. If you have clicked lately, graphic will appear where you clicked.
Horizontal control is now corrected after any change. This should fix the problem where you can't get to
either the end of the banner or back to the begining of the banner.

11-28-89

Fixed bug that caused printing to go BOMB!

Fixed object alignment bug. Objects now align corrently even scroll bars are not at home position.
Fixed scrollbar confusion problem. When objects are deleted zooms window back to the hope position.

11-22-89

Fixed a bug that occured when DAs were launched under finder.

Fixed a LaserWriter printing bug

Rewrote the Align Picture code to look more like MacDraw I1.

Fixed Paste Text bug to always select text when pasted.

Moved the Printing Status dialog down just a tad.

Added floating text, a fast way of entering extra text.

Updated sytle menu to support Underline, Condensed and Expanded Text.

11-15-89
Original Shipping Version
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